MG-Rover.org Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi there.
I have a rover metro and When i drive for about an hour or so it cuts out on me. Then i have to wait 5 minutes to start it again, or i have to bump start
the car. and it just plays up after that. please help...:(
 

·
Registered
rover_45
Joined
·
11,619 Posts
Well is it a Metro or a 100. This is important and I dont know why people call the 100 a Metro and vice versa, Try and fit a 100 bumper/bonnet onto a Metro and it wont go,

If it's a Metro it's going to be a Carb model or an early SPI one. If it's a carb model I would go with the ignition coil,

If it's an injection one then I would go with the relay pack. Same goes for the 100 unless it's a MPI one then I would say look at the coolant sensor.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Rover Metro GTa 1400

Thanks for reply,
It's a rover metro GTa 1400, i think it's fuel injected.
 

·
Registered
rover_45
Joined
·
11,619 Posts
Well helps alittle, the only snag is later Metro's had the 8V 1.4 but the early ones had the 16V SPI or TBI model in.
 

·
Registered
rover_45
Joined
·
11,619 Posts
Then I would check the fuel filter and air filter is not blocked. The fuel pump and fuel pipes could also be causing a pressure problem. When tou take the cap off does a hiss happen or not?, I would'nt rule out the fuel pump or engine ecu at this stage.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Thanks,
I get a hiss when i take the petrol cap off.
Could it be that the air valve is blocked?
 

·
Registered
Joined
·
5 Posts
hi I have a rover 200 and I have got kinder the same prob!! I have done all the basics coil, cam sensor, fuel filter, some kind of fuel relay sensor, spark plugs, pluged to computer it says no comunication. It will drive for about 5-6 miles then it dies it will start eventully but it can be 5 mins or 5 hours?????? After all the things ive done i recently noticed that even on 1/2 tank of fuel it creates a vacuum and i dont think that it normal with 1/2 tank??? So I looked it up and there is a purge tank (charcoal canister) somthing to do with fuel vapour, air and admisions and it says its part off air flow cycle there for stoping vacuum building up in the fuel tank... a vacuum it says can reduce or even stop the flow of fuel .. im in the prosess of fixing it so im not sure if thats the prob but its the only thing left.. I feel I have done everything...HOPE THIS MAKES SENSE TO YOU AND IF IT HELPS POST BACK!!!???
 

·
Registered
Joined
·
6 Posts
I've had a problem with my 1993 1.1S carb from new intermittently, whilst driving revs dip and cut out when crusing as idle or low revs, and then it cuts back it again if you tickle the accelerator... any ideas???
 
1 - 9 of 9 Posts
Top