MG-Rover.org Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
843 Posts
Discussion Starter · #1 ·
ive got a 1996 214si 16v and was wondering if i have a engine managment light? when i trun the key and the dash lights come on there doesnt seem to be one.ive looking in my rover hand book and theres no mention of one in there.

my main worry is that it could be on.a mate of mine had a pug 306 and the person b4 him took the bulb out so it would go through the M.O.T.when he put the bulb back in the light was on and when he had it hooked up there was all sorts of probs with the car.

there doesnt seem to be any sighns of the clocks being taken out so im thinking a blown bulb?
 

·
Registered
other_manufacturer
Joined
·
1,496 Posts
jay27 said:
ive got a 1996 214si 16v and was wondering if i have a engine managment light? when i trun the key and the dash lights come on there doesnt seem to be one.ive looking in my rover hand book and theres no mention of one in there.

my main worry is that it could be on.a mate of mine had a pug 306 and the person b4 him took the bulb out so it would go through the M.O.T.when he put the bulb back in the light was on and when he had it hooked up there was all sorts of probs with the car.

there doesnt seem to be any sighns of the clocks being taken out so im thinking a blown bulb?
The engine management light doesn't come on with the ignition, just the oil, battery and handbrake lights. Is the engine doing anything it should, over-revving at idle, having difficulty starting or experiencing performance difficulties that would suggest a problem with the engine management ?
 

·
Registered
Joined
·
843 Posts
Discussion Starter · #3 ·
no mate everything seems to be working perfect.thanks 4 ur reply..watch,it will come on now lol
 
1 - 3 of 3 Posts
Top