MG-Rover.org Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
Hi again,

I'm reposting my thread as have a couple of pics to add.

Basically, my drivers side seat will not move forward / backwards or up / down or recline.

I presume its not all three motors.
I have checked the 30A fuses for left and right seat, (fuses look ok) and even swapped them around, still no joy.

So am a little stuck as to where to go now.

Any advice would be appreciated.

These pics are form the rear, i did take some of the front, but theres not much really visible from front.





As you can see in pic below, there is a little pinching of the orangey/yellow wire on the left. Although i think that is for the airbags, has a yellow connector?

Regards,
Av
Milton Keynes
 

·
Registered
Joined
·
1,872 Posts
Do you have memory seats? If you do, do a search for 'memory seat diagnostics' - I posted a comprehensive set of self-diagnostic checks for memory seats a few weeks/months back.

HTH
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #4 ·
Hi,

I looked up the memory seat diags, and tried that.
Basically key to position 2, which is aux, also tried position 1, held down the memory button, and did the back/fwd/back/fwd/back switch thing.

I had no response.

Also, how do i check the switch panel? Thx

Anything else i could try?

Thanks,
Av
 

·
Registered
Joined
·
1,872 Posts
It looks like the ECU for the seat could be suspect - try reseating the connector to it for starters (that looks like the ECU under the seat, in your photos).

It's only the driver's seat with memory isn't it? (I don't have memory seats myself) because if the passenger was memory too you could swap ECUs.
 

·
Registered
Joined
·
8 Posts
It looks like the ECU for the seat could be suspect - try reseating the connector to it for starters (that looks like the ECU under the seat, in your photos).

It's only the driver's seat with memory isn't it? (I don't have memory seats myself) because if the passenger was memory too you could swap ECUs.
Hi,

I have exactly the same problem with my driver's seat. The garage want £607 for a new ECU. They say it must be new, a used one won't work.

I think I will have to forget a repair but I don't like the idea of it not working.
 

·
Registered
rover_75
Joined
·
36 Posts
I have had a similar problem with mine. The only solution that I have found that works is to disconnect the battery after turning off sat nav. Leave for at least half an hour. Reconnect, insert and turn igintion key without closing door. Seat then operates for a while with door open.
 
1 - 7 of 7 Posts
Top