MG-Rover.org Forums banner

1 - 6 of 6 Posts

·
Registered
rover_400_95_99
Joined
·
111 Posts
Discussion Starter · #1 ·
Hey folks.....please pray to the messiah of HGs as per the above.

Long story short, lost heat from the cabin heater on Sunday. Checked coolant - VERY LOW!!! Topped it up, heater was then fine.

Took her 60mile round trip on Sunday. Checked coolant again and it was fine, couple of drips on the ground, nothing too concerning.

Checked again yesterday and it was low, but not as low as it had been. Topped it up, then checked for leaks....still nothing on the ground, or sitting anywhere in the car (except for a small amount on the under bumper splash guard, but nothing too worrying.

The hose from the rad to the stat goes hard under pressure and water is in it, cos when I squeeze it, it bubbles up in the header tank, as it always has done.

I'm plannin on bungin some rad-weld in it asap, just in case it's a small hole somewhere and the stuff may work, (as it has before) even temporarily!

This along with an INTERMITTANTLY wet exhaust has me bricking it at the thought of the blessed HGF on a 2.0 K series!!!!

Any advice folks? (other than selling up before someone notices!!! lol)
 

·
Registered
Joined
·
2,153 Posts
rads are poor

if it has a black copper core it will be goosed .


also steel pipe just below the rad is prone to rot .

picture looking up from underneath car on axel stands.
belly pan removed




all the best.mark
 

·
Registered
Joined
·
4,115 Posts
I had a lot of rust in mine that was about to start leaking, good thing I fixed it before it did any damage.
 
1 - 6 of 6 Posts
Top