MG-Rover.org Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I was about to go out in the car everything seemed find.
Then I noticed my temperature gauge and fuel gauge had both switched off. My rev counter had frozen, my VDU had gone off, and my air con now has er displayed. I have to lock the car manually, but will open as normal using the button on the key.
It did this first last month for a few seconds and came back on,
now its permanent.

Any one have any ideas??
 

·
Registered
cityrover
Joined
·
13,055 Posts
Dr Dave said:
Disconnect the battery for 5 mins.....try that.
Yep i also vote for, unplug it for 5 mins and the plug it back in again, same as many other electrical items!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
No didn't work!

Had the battery disconnect for 15 minuets.
Reconnected everything was the same.
Even the radio worked and didn't need any code.

Both pos and neg cables were removed

Any more idea's guys
 

·
Registered
Joined
·
585 Posts
totally disconnected, if its a rover stereo then it should have needed the code put in, i am hopeless with electricals but clearly its holding a charge somewhere it shouldnt.......hopefuly an some of the forums electrical gurus will be along to help........

is everything else working as it should, immobilisor/clocking, electrics? and simple things too have you checked for any fuse damage?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #8
Yes its a rover sterio.
I know seem a bit strange.
Nothing attached to the battery what so ever
 

·
Registered
Joined
·
12 Posts
Discussion Starter #10
Still nothing is working on my dash.
Also have to lock the car manualy.
can open with key.

Any recommendations
 

·
Registered
Joined
·
12 Posts
Discussion Starter #12
I've checked the fues's even swapped some over.
Not changed anything.
it did happen before while I was driving then returned back to normal after about a mile. Speedomitor and rev counter froze, fuel and temp droped.
Couldn't see if I was indicating, but they were working
 
1 - 15 of 15 Posts
Top