MG-Rover.org Forums banner
41 - 52 of 52 Posts

·
Registered
rover_400_95_99
Joined
·
101 Posts
Discussion Starter · #42 · (Edited)
Hi!

Here is the problem with the engine, one of the inlet valves, the left one in the picture, of the third cylinder from the cambelt side is leaking. You see it on the picture. I am about to change it.

Don't know if I should do anything more like changing the camshaft followers, tappets when i have the old, original ones with the small oil holes?
But it seems a little pricey.

Best regards!

Martin

Eye Automotive lighting Hood Automotive tire Motor vehicle
 

·
Registered
rover_400_95_99
Joined
·
101 Posts
Discussion Starter · #43 · (Edited)
Do anyone know where from i can order the new modified hydraulic tappets, camshaft followers?
The one that according to Haynes manual "with drilling leading to oilrail".

Best regards!
Martin
 

·
Registered
MG ZT, Rover 25
Joined
·
5,813 Posts
I don’t know, try Rimmers? Unless there is a problem I wouldn’t replace anything but the bad valve and stem seals, grinding in the valves so they seal well when refitting.
 

·
Registered
rover_400_95_99
Joined
·
101 Posts
Discussion Starter · #45 · (Edited)
I don’t know, try Rimmers? Unless there is a problem I wouldn’t replace anything but the bad valve and stem seals, grinding in the valves so they seal well when refitting.
Hi!
I asked Rimmers but no answer so i bought the original ones from Autodoc. But unfortunately i didn't help. I have not find the problem with the motor yet, had the car to a garage but they didn't find the problem either.
So you where right, it was unnecessarily to buy them and expensive too.

I am out of ideas, bide my time now. Maybe i did not grind the valves enough when i fitted the new one.

It's like the engine is running with a strong curb, restrain like a hourse that you holding back. It is weak an when it's cold it's even weaker. And it runs a little uneven to. But when i rev it without load it revs beatifully.

Best regards!

Martin
 

·
Registered
rover_75
Joined
·
301 Posts
Martin, where do you live? Can't help much with mechanical issues as I've only owned V6s, but if you think it could be electronically related, I have a Rover T4 diagnostic computer in Gävle
 

·
Registered
rover_400_95_99
Joined
·
101 Posts
Discussion Starter · #48 · (Edited)
I'd re-check the timing if you haven't already....
Hi Gnu!
Yes i might do that again. I think it is something with the third cylinder but I am not sure. Will keep searching.

Could something have get out of order when i reassembled the engine?
Or is it just to check the timing and that's enough?

Best Regards!

Martin
 

·
Registered
rover_400_95_99
Joined
·
101 Posts
Discussion Starter · #49 ·
Martin, where do you live? Can't help much with mechanical issues as I've only owned V6s, but if you think it could be electronically related, I have a Rover T4 diagnostic computer in Gävle
Hi Vitesse!
I live in Tumba south of Stockholm. I don't know if it is eletronically related but it could be. Thanks for your concern, I'll keep your T4 in mind.

I am a lite fed up with the car just now. I also must change the windshield, it didn't pas motor vehicle inspection (MOT). They found one in Germany, luckily.

But i do want the engine back on full power so i will keep searching!!!

Best Regards!

Martin
 

·
Registered
rover_75
Joined
·
301 Posts
Hi Vitesse!
I live in Tumba south of Stockholm. I don't know if it is eletronically related but it could be. Thanks for your concern, I'll keep your T4 in mind.

I am a lite fed up with the car just now. I also must change the windshield, it didn't pas motor vehicle inspection (MOT). They found one in Germany, luckily.

But i do want the engine back on full power so i will keep searching!!!

Best Regards!

Martin
Well not that far then just, once you clear Stockholm, 2 hrs up the road. Know how you feel as I'm chasing a SRS fault on my daughter's ZS180 and a s/h replacement sensor hasn't helped, it needs a new windscreen too.
Anyway I'm here in Gävle with I believe the only T4 in private hands in Sweden, no charge, just happy to help keep Rovers/MGs running. Not so active on here but you can always contact me via the Sw Rover 75 FB group (Facebook Groups)

Regards
Mike
 

·
Registered
MG ZT, Rover 25
Joined
·
5,813 Posts
IMO the T4 is a good idea and nice offer from Vitesse. It will advise on engine faults so could help.
 

·
Registered
rover_400_95_99
Joined
·
101 Posts
Discussion Starter · #52 ·
Well not that far then just, once you clear Stockholm, 2 hrs up the road. Know how you feel as I'm chasing a SRS fault on my daughter's ZS180 and a s/h replacement sensor hasn't helped, it needs a new windscreen too.
Anyway I'm here in Gävle with I believe the only T4 in private hands in Sweden, no charge, just happy to help keep Rovers/MGs running. Not so active on here but you can always contact me via the Sw Rover 75 FB group (Facebook Groups)

Regards
Mike
Thanks Vitesse!
I will take this under consideration, maybe i come knocking on your door sooner than later, of course after we have come to an agreement.

Best regards!

Martin
 
41 - 52 of 52 Posts
Top