MG-Rover.org Forums banner
1 - 18 of 18 Posts

·
Banned
Joined
·
0 Posts
Discussion Starter · #1 · (Edited)
my 75 has climate control with air con however i cant get it to blow ice cold it blows cold air just like and ordinary fan controlled car.
i put the auto switch and econ switch to off and still no cold air.
ive done a search and tried what people are saying but ive still got no ice cold air/ what am i doing wrong?
please dont give me technical terms as i dont have a clue!!! a simple step by step guide for a simpleton please:fishslap: what do i need to check and what order.
thanks
just been to halfords and bought a refill tin with pressure gauge however when i connected it it read alert overcharged what does this mean? what do i do?
 

·
Banned
Joined
·
9,909 Posts
Take it to your garage or an air con specialist and ask for it to be regassed. Lack of gas in the system is the most likely culprit

Mike
 

·
Registered
Joined
·
3,168 Posts
7T5 said:
my 75 has climate control with air con however i cant get it to blow ice cold it blows cold air just like and ordinary fan controlled car.
i put the auto switch and econ switch to off and still no cold air.
ive done a search and tried what people are saying but ive still got no ice cold air/ what am i doing wrong?
please dont give me technical terms as i dont have a clue!!! a simple step by step guide for a simpleton please:fishslap: what do i need to check and what order.
thanks
Please don't shout but as you say you haven't got a clue, the temperature is set low enough for the cold air to come on isn't it?

I know its obvious but just checking.

Ken
 

·
Banned
Joined
·
0 Posts
Discussion Starter · #4 ·
hi
the temp is set to low and tried it set to 16 as well and only get cool not ice cold air!
ive tried it with econ off and auto off and at various temps the fuses seem to be fine.
ive tried it with the recirculate button on/off too, in one of the threads it mentions looking for a fan to come on when switched on is this the big fan at the front?
thx
 

·
Registered
Joined
·
3,168 Posts
7T5 said:
hi
the temp is set to low and tried it set to 16 as well and only get cool not ice cold air!
ive tried it with econ off and auto off and at various temps the fuses seem to be fine.
ive tried it with the recirculate button on/off too, in one of the threads it mentions looking for a fan to come on when switched on is this the big fan at the front?
thx
When you switch it on its very noisy, if you can hear the fan its working. Back to what Mike say's I'm afraid looks like a re gas.

Have you had no climate control on over the winter? its best to run it quite often to stop the seals from drying out. If your seals have dried a little that allows gas to escape and means a re gas. I run mine all the time just to keep everything running and the gas circulating.

Ken
 

·
Banned
Joined
·
0 Posts
Discussion Starter · #6 ·
hi
no i havent had the car long so never used it till recently.
just been out to try it with the bonnet open and the grill off and the radiator fan doesnt come on but there is a noise that something is switching on and makes a groaning noise for a few seconds then goes off and comes back on after around 20 seconds,i can hear it from the air vents in the middle of the dash near the clock i left the car run for around 15 mins the temerature gauge stays in normal.

how much should it be for a regas? is it dear?

ps there is a very mild gassy smell when its switched on a bit like compressed air from the garage when filling tyres
 

·
Banned
Joined
·
0 Posts
Discussion Starter · #8 ·
done a diagnostic check but only get codes 21 22 but that was expected due to ill light however it didnt show any other faults im puzzled now
 

·
Registered
Joined
·
5,662 Posts
it read alert overcharged what does this mean?


Without sounded clever, you have answered the question yourself in your initial post.Overcharged mean excess gas which means it needs recovering properly and the correct amount of refrigerant being put back in.
 

·
Banned
Joined
·
0 Posts
Discussion Starter · #10 · (Edited)
hi lates
theres a gauge on the can and it has green for need filling blue for ok yellow for overcharged and red for seek mechanical help i tried to fill it up and it went to yellow.hi youre probably right but it wasnt working before i tried to refill it up,why does the compressor only work for a few seconds then?so any suggestions would be very welcome
thx
 

·
Registered
Joined
·
5,662 Posts
Best bet is to start off with a known quantity of refrigerant and get the system serviced.Also and imo dodge the can of gas goo.
 

·
Banned
Joined
·
0 Posts
Discussion Starter · #12 · (Edited)
lucikly theres a garage 900yds away from me and he does aircon so i think ill be giving him a call on tuesday :err: hope its not too expensive
is there a seperate fan for the aircon? where is it can it be seen? when i take the grill off i can see the radiator fan but it doesent go round after 15 minutes running engine however temp gauge stays at normal.
and would it help if i pull the relay out and refit it? where is it!!!!

thx
 

·
Registered
Joined
·
5,662 Posts
The relay pack is built into the fan assembly.One fan does all i'm afraid.
Getting back on track, once your garage has correctly "dosed" up the air conditioning system, then go on the hunt for fan issues or more temp related problems.
 

·
Banned
Joined
·
0 Posts
Discussion Starter · #14 ·
apparently my fan doesnt come on although the compressor does work intermittently.so would it be worthwile getting it regassed first?
thx
 

·
Registered
Joined
·
5,662 Posts
I think you have 2 issues on your vehicles. The fan issue and gas weight issues. One of the reasons the compressor will work intermittantly if the system pressure is too high it will shut down to prevent compressor damage.
 

·
Banned
Joined
·
0 Posts
Discussion Starter · #16 ·
thanks for that its a big help,i will take it to the garage on tuesday and see what he says, lets hope its not expensive!!!!! if worst comes to the worst ill have to do without.
 

·
Registered
rover_75
Joined
·
67 Posts
May sound stupid but there'sa little knurled slider knob near the top of the dash in the centre ... it makes a big difference turn it to the blue roundel ... try it ... good luck Roger
 
1 - 18 of 18 Posts
Top