MG-Rover.org Forums banner

941 - 960 of 988 Posts

·
Registered
mg_zs
Joined
·
1 Posts
Mgzs

My MGZS 1.6 05plate, i wanted a mgzr originally but when i saw this for sale and not far from where i live i couldnt resist :) more pics to follow..

[/IMG]
 

·
Registered
Joined
·
568 Posts
Misfire at low idle

Ok... My car started to develop a misfire, I thought it was Inlet manifold because it was always on idle or low idle when it misfired and when I start the car in the morning I've done the inlet manifold and I've changed all four spark plugs now the very best NGK laser platinum one's. I thought this would sort it but it hasn't :(

I went for a drive after doing all this only to find that the car still misfires, once the engine runs over 2000rpm whether travelling or sat still the misfire goes. Yet sat on idle or at a junction it misfires.

What could it be a Injector? Oh I've checked all HT leads aswell I took each ht lead off the spark plug one at a time and each cylinder dropped out as it should do. I have engine management light on so might just get the code read and save the hastle

Any thoughts guys feel free to ask any questions...

Steve
Looks like you've got a faulty coil pack. If you get a new one, try changing one side then if it still does it swap to the other side. This should sort your problem as I wouldn't think both packs would go faulty at once and not a long job. Posted in the wrong section by the way.
 

·
Registered
rover_100
Joined
·
164 Posts
been more than enough years

Hi, i've missed being in these parts of the internet
As i've sold my 416 some years back, i still hold it to my heart


so here is a pic i dug up om my beloved car :) before i sold it.

many hours went (and money) in making it special and i regret selling it but...



hope everyone back from the day are well and enjoy their hobby.
 

·
Registered
mg_zs
Joined
·
9 Posts
Sorry to hear your pain, did you manage to get it sorted or at least find out what is wrong?
Intake mani had ate itself. Mechanic reckons a couple of VIS valves had jammed shut and starved the engine of air. Engine is currently idling smoothly with the valves ripped out but is hesitant to rev, ive ordered a 2nd hand mani from eBay for £120 it should be here next week and ill see then if it works.

Your mk2 looks fantastic though by the way. I was trying to pick one up but the only one for sale was down near London when I bought my mk1.
 

·
Registered
mg_zs
Joined
·
9 Posts
the valves won't really jam shut beacuse of the air movement would be enough to open them under acceleration.......................
Ah it is only speculation. we couldnt figure out what else would cause it to hesitate/loose power during a long motorway cruise. Just gotta drive it and see if any niggles crop up again. The inlet mani was definetly f-ed though so Im not loosing anything by shoving another one on.
 

·
Registered
rover_45
Joined
·
1 Posts
941 - 960 of 988 Posts
Top