MG-Rover.org Forums banner
1 - 4 of 4 Posts

·
Registered
rover_200_coupe
Joined
·
2,261 Posts
Discussion Starter · #1 ·
Sometimes when I turn my car off the battery light comes up for a split second . Is this anything I should be worried about ? Car starts and runs OK .
 

·
Registered
other_manufacturer
Joined
·
1,496 Posts
Darwin said:
Sometimes when I turn my car off the battery light comes up for a split second . Is this anything I should be worried about ? Car starts and runs OK .
Surely it's just the key turning through the second intermediate position on the ignition.

If everything is running fine, then there's nothing to worry about, but if your bothered, a quick check with a multimeter across the battery and check for alternator output can't do any harm.

ashy came across a multimeter at Maplins for £5, and they're useful to have, so if your worried, I'd give that a bash.
 

·
Registered
Joined
·
25,606 Posts
Darwin said:
Sometimes when I turn my car off the battery light comes up for a split second . Is this anything I should be worried about ? Car starts and runs OK .
Normal. You turn the igntion off. The engine is still turning so the alternator is still charging to some degree so the charge it develops feeds back through the battery warning light whilst the engine is still spinning. If you had an older rover which were more prone to "running-on" then you'll see this happen quite often.
 

·
Registered
rover_200_coupe
Joined
·
2,261 Posts
Discussion Starter · #4 ·
Cheers guys . Its a 95 620 Ti . My last car was a 95 820 Vitesse with the same engine and I dont remember it doing this .
 
1 - 4 of 4 Posts
Top