MG-Rover.org Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
hi
ive got a m reg 115 metro diesel a couple of days ago the battery light came on the dash the car was still running fine my partner took it to a garage because he though the alternator had gone but thats fine the car now wont start unless its jumped we had the battery checked and thats fine charging 12 volts but should be 14v? weve had some oil leeking so my husband took the alternator off and cleaned everything and tightend the belt and removed the rust from the connecting wires the battery light is still on on the dash and still wont start anyone got an idea of what it could be as im desperate to have it sorted soon because i only passed my test 2 weeks ago and now i cant drive
 

·
Registered
Joined
·
10,841 Posts
How old is the battery on the car? Could just generally be stuffed...

Or the alternators is playing tricks on you :(
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
not sure how old the battery is but we havent changed it in the last 4 years
the cars not turning over but the lights on the dash are on
thanks
 

·
Registered
Joined
·
10,841 Posts
I remember on my dads 800 diesel. It was a fairly decent battery and it wouldnt start (it was trying to turn over) and all the lights windows etc.. worked perfectly.
I said it was battery and my uncle tried to jump it off his disco, didnt work. I did it of fmy 600 diesel (with fresh new 700cold crank amp battery) and she fired straight away.

Check see see if its the right one, dervs take a little more to start :)
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
hi
when my hubby jumps it from his metro it works fine and drives well but when he turns it off it wont start up angain unless its jumped
cheers
 
1 - 9 of 9 Posts
Top