MG-Rover.org Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
162 Posts
Discussion Starter #1
Hi, basically I am rebuilding a kitcar called a GTM Libra, but all the running gear is mg/rover so I am hoping someone on here may know.

The car usedto have a 1.6 k series motor (mems 1.9 i think) The rover motor not the honda one.

I have replaced it with a vvc 160 mems 3 motor from a TF.

Basically if anyone on here has put a vvc mems 3 in a rover 25 etc or similar then it'll be a very similar excercise wiring wise.

I have pretty much all the wires wired in apart from a few from the smaller ecu plug





And 2 brown wires to the relay pack (im guessig these are a live to the relay pack but itd be great if someone could confirm) and also a white wire from the relay pack which isnt on the pic





If anyone has done a similar conversion and could tell me where the wires go or what they do, that would be great. It's likely that some of the wires may not even be needed, i just want the thing to run, the 5as, immobiliser side etc is all done and working. It is literally just the wires shown I need help on.

Would massively appreciate it if anyone could help!

Thanks

Ryan :)



 

·
Registered
Joined
·
8,194 Posts
there have been a few people on here that have upgraded to the VVC but I think that most try to keep in with the same ECU. i.e the older VVC units did not have MEMS3 so older cars try to use this engine.

Sorry I cant be much help! but hey its a free bump! That GTMs are fast! I had a red one up my trumpet yesterday and was surprised at how well it kept up!
 

·
Registered
Joined
·
3,430 Posts
Don't you need the ECU and the wiring loom that go with the new engine? I thought other ECU's don't work with the later TF engines particularly the 1.6 or 1.8 MPi.
 

·
Registered
Joined
·
162 Posts
Discussion Starter #5
It's a mems3 16o vvc motor, with the mems 3 engine loom and ecu and matched up 5as etc. It's all the correct stuff. But the loom on my car is a rover 25 loom i think so its a case of matching the mems 3 mgtf loom to that.

They are quick, 0-60 around 5 - 5.5s. Only weighs 750kg and mine has a closer ratio box. Been thinking about that vsport remap ive seen on here too.
 

·
Registered
Joined
·
8,194 Posts
I think there was an MGF on here that recently converted to the 160 Engine from a MGZR. I assume he would of had to do the same. Ill try remember the thread name
 

·
Mmmm....Rover..
Joined
·
10,426 Posts
The two Brown wires from the relay module should be connected to a permanent 12 volt supply.

There are a few White wires shown on the diagrams for the module but all have an additional tracer colour.

From your picture I have deduced the following wire colours...

Blue/Orange: Switched ground for the engine warning lamp.

Purple/Brown: ECU Ignition 12 volt supply.

White/Black: Tachometer drive.

Yellow/Red: Serial Data link to the 5AS (immobiliser).

Green/Black: Input into the ECU from the Fuel tank sender.


The colour of the other 3 wires is difficult to determine from the picture, maybe you can post up their details.
 

·
Registered
Joined
·
162 Posts
Discussion Starter #8
The two Brown wires from the relay module should be connected to a permanent 12 volt supply.

There are a few White wires shown on the diagrams for the module but all have an additional tracer colour.

From your picture I have deduced the following wire colours...

Blue/Orange: Switched ground for the engine warning lamp.

Purple/Brown: ECU Ignition 12 volt supply.

White/Black: Tachometer drive.

Yellow/Red: Serial Data link to the 5AS (immobiliser).

Green/Black: Input into the ECU from the Fuel tank sender.


The colour of the other 3 wires is difficult to determine from the picture, maybe you can post up their details.

I'm going to the garage now after work so I'll get the rest of colours, thanks for this!!
 

·
Registered
Joined
·
162 Posts
Discussion Starter #9
I think there was an MGF on here that recently converted to the 160 Engine from a MGZR. I assume he would of had to do the same. Ill try remember the thread name
Thanks, might be useful that thread if you could find it! Like you say it must be a very similar exercise..

Even just knowing what the wires do helps because I may not need them all, or what supply they need then I can give them a live feed
 

·
Registered
Joined
·
162 Posts
Discussion Starter #10
Okay there is also;


Black

Black/Brown

Pink/Black - (it looks pink anyway)

Red/Green



And just that white from the relay box.... any idea what that does or what feed it needs?

thanks !!
 

·
Mmmm....Rover..
Joined
·
10,426 Posts
Found 3 out of the 4, the wiring diagrams do not show a Red/Green or Green/Red wire fitted to the smaller ECU connector.

The White wire is either the 12 volt supply for the starter motor relay or the ECU switched ground for the main relay, all of the diagrams show the white wires as also having tracer colours (red, orange or pink).



Okay there is also;


Black Ground connection.

Black/Brown Engine Bay Cooling Fan Relay - ECU Switched Ground

Pink/Black - (it looks pink anyway) Inlet Air Temperature Sensor

Red/Green ----


And just that white from the relay box.... any idea what that does or what feed it needs?

thanks !!
 

·
Registered
Joined
·
162 Posts
Discussion Starter #12
I'm not quite sure what you mean by switched ground can you explain? The main one I'm stumped on now is the white one and the one for air temp sensor, as all the sensors are plugged in already on the engine loom... The mems 3 small plug is from a vvc mgf but my engine is from a mems 3 tf, that might mean differences in some of the wiring. Either way that's narrowed it down a lot! Thanks :)
 

·
Mmmm....Rover..
Joined
·
10,426 Posts
Switched Ground: Generally the relays will have a permanent or ignition 12 volts to one side of their coil and the other side is connected the ECU, it switches this side of the coil to ground internally, thus turning the relay on or off.

The Green/Red wire is for the dash "Engine Bay Fan Warning Lamp", I was using the TF diagram... this lamp was omitted on that model but is present on the F.

The Pink/Black is for the Engine Bay Fan Temperature sensor NOT the Inlet Air Temp, my mistake!!

Which of the two connectors on the relay module has the white wire and what are the adjacent wire colours?
 

·
Registered
Joined
·
162 Posts
Discussion Starter #14
Are the rest of the wires you told me before the same as you said? My fault i shouldve told you the small plug im using was off a mgf before.

I think the white wire is from the larger plug, if not its the other theres only 2! (very accurate arent i!)



It's looking like most of these wires aren't even necessary to make it run!
 

·
Registered
Joined
·
162 Posts
Discussion Starter #15
Are the two browns still lives on the mgf diagram too?

sorry for all the questions! and thanks for the help!
 

·
Registered
mg_zt
Joined
·
89 Posts
So did you get it running, basically I am doing a similar conversion but its an MGF 143 MEMS2j to 160MEMS3. so I am facing the same decision which is to rewire the smaller plug into the MRU, (black relay box) for most of its connections, and some additional ones like the constant 12v to MEMS3 etc..

If you could send pics -> did you end up splicing anything into the main ECU bigger plug, or was it only the smaller plug that needed pairing... thanks in advance. trevor.
 

·
In the Garage
MG TF
Joined
·
32,915 Posts
I doubt you will get a reply as sadly yazza54 hasn't been logged in to the forum for 4 years.
 
1 - 17 of 17 Posts
Top