MG-Rover.org Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter · #1 ·
Anyone whose read my threads recently will know what a time I,m having with my rover 75,just now, well I fixed the bolts that had snapped,I,ve now replaced the driveshaft as the other one had bent,probably when bolts snapped.
put it all back together yesterday to find my sump is now leaking on one corner ,gggrrrrrrrrrr,now I,m really red up.
we,re supposed to be going on holiday to Cornwall on Sunday,I dont think I trust the car to drive 350 miles there and then back again,I,m really starting to wish I,d never seeen the blinking car.
thank goodness we,ve got breakdown cover.
any guesses as to why the sump is only leaking in one corner.
 

·
Registered
mg_zt
Joined
·
307 Posts
From a corner must surelly be either a crack or gasket probolems?

Often then use sealents on the sump dont they which could have been disturbbed while you were down there.

Have to admit i have not dealt with this problem but thats the way i would atart.
 

·
Registered
Joined
·
428 Posts
Tim, sorry got me little confused here.... are we talking about the Rover P6 in the photo, or a newish Rover 75. I served my time on the old Rovers many moons ago.
Just check that the oil isnt running down from further up the engine, if it is a newish car then check the oil filter housing to mmake sure it is comming from there. On the P6 people used to get a small cable traped in the edge of the oil filter housing which led to a small but anoying leak... forgive me if you have already tried this but its wortha try.
we have only just bought our ZT -T diesel and its been great so far.... off to the south of france towing the caravan next weekend.
good luck
J
 
1 - 4 of 4 Posts
Top