MG-Rover.org Forums banner

1 - 8 of 8 Posts

·
Registered
rover_75
Joined
·
169 Posts
Discussion Starter #1
Hi again,
I recently asked for advice about my instrument pack problem where the rev counter and temperature gauges rarely work and it seems from further tests I have done that the pack is faulty.
I did some research on the chip that accepts the Canbus signals from the ECM and found that pin 8 controls whether the chip is active or in standby mode, depending on the voltage/current at pin 8. For the chip to be active the voltage has to be less than 0.3 volts. Mine is at 2.51 volts. It is difficult to go further and decide why this is so, as the voltage comes from another chip via a resistor, and it seems that the 2 chips talk to each other, so either could be at fault. I could get one of them (manufactured by Philips), but not the other as a search on Google revealed nothing about it.
So I have decided to ask the dealer to order a new pack, regardless of what colour the backlighting will be. Apparently they are on back order and it may be the case that more will only be manufactured if there are enough orders. They also said that the version with a trip computer is available from stock. I assume that this is the version with the message centre, which mine is not.
What I would like to ask here is whether anyone can tell me if the message centre version will work properly where it was not used before?
Also if it won't, any ideas as to what would be needed to make it work properly if anyone has tried it? As far as I can see the wiring diagrams on the Rave CD show the same 2 connectors for all versions, and there does not seem to be anything different for various manual versions, which mine is. Or would it be a case of the ECM and maybe other modules needing to match up with the different instrument pack? If that is the case then I don't want to have to replace things that are not faulty and would have to maybe search for a basic secondhand one. I am so fed up with not having other things like the aircon not working because of it, I am even prepared to put up with a pack that registers higher miles than mine.
Thanks in advance for any expert help.
Charlie Hall
 

·
Banned
Joined
·
9,909 Posts
You need to search for jamescj thread about the instrument pack. He posted it on the 75&ZT forum. It will tell you all you need to know :)

hth

Mike
 

·
Registered
rover_75
Joined
·
169 Posts
Discussion Starter #3
Hi Mike,
I appreciate your help and had done a search for instrument pack, then read your reply and have searched that forum and all others and not found the thread you refer to yet.
Can you help with the thread title please? It must still be there somewhere?
Regards,
Charlie Hall
 

·
Registered
rover_75
Joined
·
169 Posts
Discussion Starter #4
Please ignore my last message, I found the thread. Looks like I can use the message centre version.
Regards,
Charlie Hall
 

·
Registered
Joined
·
4,899 Posts
Dont forget you need the stalk as well. All plug and play though just needs to be coded and configured on T4 by the dealer. Not a hard job at all.
 

·
Registered
rover_75
Joined
·
169 Posts
Discussion Starter #7
Yes, I have read one or two things about the stalk. Though I would like to know exactly what it does that can't be done without it. I thought up till now that it was just an extra way of controlling the same function as the front button of the instrument pack.
If I have to and can get one, will it need to be fitted before the dealer programs the new pack or could it wait?
Or can I do without it at all and not suffer other unwanted side effects?
Regards,
Charlie Hall
 

·
Registered
rover_75
Joined
·
169 Posts
Discussion Starter #8
I saw a thread that mentioned Digi-Dash. After doing a search with Google it looks like there are 2 different companies with the same name, with different phone numbers for each.
Could someone please confirm which is the best one to contact?
I am thinking after reading one of the sites who says they can repair instrument packs (R75 is mentioned) that the original pack might be repairable if it has a corrupted eeprom. Would think it must the best option to look into at the moment.
Regards,
Charlie Hall
 
1 - 8 of 8 Posts
Top