MG-Rover.org Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi, Surfed it earlier today looking for cam belt schedules, I believe it to be 5 years or 60,000 miles. Car was 5 in March so will get it done shortly. Anybody near Glasgow/Paisley like a homer?

Lowest two speed settings on heater blower are not working. Advise @ last service was that resistor had burnt out, they wanted £85 to fix (not on) Does anybody know where the component is and how to fix problem?
Car registered March 02.
 

·
Registered
Joined
·
1,108 Posts
Heater blower

Take a look in the "How To..." section and there is a guide to fix this exact problem. Trust me it works and as good as ever.

HTH
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thanks

Thanks for that 214, looks like a piece of cake. I take it the new part comes already soldered to the plate? Or do I have to solder the "Springs" onto it myself?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Thanks

Yes I did know that, but there is a fix further on in the how to section which shows resistors having to be soldered in but think this is for older models where the 3 resistor coils are separate.
 

·
Registered
Joined
·
1,108 Posts
check ebay i got one for £25 and it isd behind the glovebox took me about 30 mins to replace
£25 :eek:mg: cost me 3 quid and twenty minutes of my time. Problem with getting ones from ebay (especially if second hand) are that the problem could happen again as you won't know how old it is.

If you want to replace like for like you'd be better off getting one from a scrappy as it will be a lot cheaper. They sell them that expensive on ebay as it's a common problem and people with pay anything to get it fixed.lol.

HTH :)
 

·
Registered
Joined
·
4 Posts
Heater Blower Control MG ZS

Hi ,I have experienced the same problem with my 2005 ZS 120 ie,heater not working on the two lower speeds ,and having read these threads I have two questions.
Firstly ,what is the part No of the resistor assy that I need to locate on e-bay?, and secondly, where do I find the"How to" page on this web page?
Best wishes ,Alan
 

·
Registered
Joined
·
7,879 Posts
Hi ,I have experienced the same problem with my 2005 ZS 120 ie,heater not working on the two lower speeds ,and having read these threads I have two questions.
Firstly ,what is the part No of the resistor assy that I need to locate on e-bay?, and secondly, where do I find the"How to" page on this web page?
Best wishes ,Alan

http://forums.mg-rover.org/forumdisplay.php?f=8

How to section.
 
1 - 11 of 11 Posts
Top