MG-Rover.org Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi All

Hopefully you might be able to help, i bought Project 400 and all was well until the other week when the Stereo packed up earlier in the day. Then the heater Fan stopped working on the Sunday when you turn the switch nothing comes on so the car is steaming up and the heater has not worked since

Took all of the fuses out today to check and they all seemed ok wondering if this could this be linked to the earth problem that was fixed previously. Could one of the screw in fuses under the engine be the problem?

Grateful of any advice that you all can give as new to rovers and would like to get it sorted and the car reliable. (I think i have solved the reliable part by getting a new plip programmed by Lates, i was having a problem starting it which seemed to be down to the immobiliser being on even after the plip was pressed to open the doors.)

Cheers Gary

PS Dr Dave or anyone who can help, is the earth for the heater / cigarette lighter a push on one under the steering rack (clicked this is the earth for the clock, it goes off each time i pull it :) ) or behind the bonnet release catch which is labelled as C110 / C111 on the drawings have searched all over and these are the only 2 i can find

Grateful of any help, don't have a problem with Peugeots but Rovers are an unknown issue for me
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Grateful if someone could confirm that i am looking in the correct place, off work tomorrow so going to have another go at trying to sort it out
 

·
Registered
mg_zs
Joined
·
222 Posts
The heater fan could be the resistor which is behind the glovebox,a smallish oblong thing with a small electrical plug going to it,take the two screws out and it should lift up and out (best thing,buy a Haynes,will save you a load of agro)this is a commen fault,some one on this sight does an upgraded one which ive put in mine as i had same problem but ive forgotten who,sorry.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 · (Edited)
Please some one help as the skip is still causing problems

Update

unbolted the earth connection C110 / C111 above the bonnet release catch in the drivers footwell and cleaned up the earth and paintwork as it looked a bit rusty (Had not replaced it). Then took the earth connection off by the battery under the bonnet (White block) and cleaned the metal connection and the paintwork (did not re screw this in and went to check the heater earth. Turned the key to 2 and touched the heater earth C110 / C111 to bare metal and the heater blower started up and was working fine. then made the mistake of checking the cigarette lighter. As soon as i pressed this in the heater stopped working. Have taken the cig lighter out and will buy a new one tonight and replace (Did this and the Cigar lighter still does not work). But no matter what i do cannot get the heater blower to work again. even tried rigging up a earth bypass from the cig/heater earth to the clock earth but still not working with both earths not connected the clock still worked so have disconnected the bypass. Have checked the resistors behind the glovebox and they are all ok and all the fuses Are ok with none blown. I am not an electrician so would be grateful of any more advice and what to do next.

Any advice gratefully received, as worried next thing to do is the centre console?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Radio problem solved

Had a look at the CD Radio tonight and solved the problem why that is not working the cable between the mask face and head unit is broken so off shopping for a new cd player tomorrow.

Would still be grateful of any advice as to whats wrong, quick question the white earth block by the battery? what is this the earth for? Think its time to work out how to take the centre console apart in the morning. But don't think this is the problem as feel its still linked to the earth by the bonnet release catch by the pedals. Please correct me if i am wrong
 

·
Premium Member
Joined
·
79,177 Posts
That's the one down by the pedals that I cleaned up/moved when I fixed the fan last time.

This is indeed a very odd problem. What about if you isolate the cigar lighter from the circuit?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 · (Edited)
New idea

Have decided to take the centre console out and put in new earths directly off the cigarette lighter and heater switch as think the problem might actually be a broken wire as it would not even work when i added a jumper in off these wires back to the earth for the clock, will cut the wires in the morning first and re crimp on new connectors and try to reseat it before taking the centre console out.

Also meant to say i have removed the cigarette lighter and hope this might help

Has anyone any advice as to what the earth block (white in colour by the battery) is earth for?

Fitted a brand new JVC stereo this morning, took all of 10 minutes and great to have some music in the car again. So the old Kenwood has been taken down the recycling centre. (Oh what it is to be eco friendly:happy: ) So at least that made me feel a bit better as was worried it was a bigger electrical problem and now know it is just an earth problem.

Thanks to Lates for programming another spare plip for me so yippee now have a spare set of keys. Just in case as have 3 boys and things go missing very easy.

Have a vax being delivered next week so will valet the car inside and have a friend going to steam clean the engine bay as noticed some fresh oil in the engine bay and want to locate where it is leaking from. Then gong to t cut the car down and have chip master sought out the paintwork. Will look a million dollars when finished especially with the new rear bumper and rear spoiler that i will fit

Anyone know how hard it is to add Air con into a rover that did not have it fitted as standard? The wife is going to love this car when i have finished.

Now decided that will not get a new 407 when my insurance pays out for my last two write offs (both within 24 hours, ouch!) and started looking for a MG ZS 180 as started to realise what the addiction is. Glad i took out Zurich insurances lifetime no claims protection.
 

·
Registered
rover_45
Joined
·
11,619 Posts
Fitting air con to a mk2 400 is not a big job. Rover sell a kit to fit it but it comes in three parts and by the time you add them all up it will cost you about £800 plus the fitting of it.
 

·
Registered
Joined
·
5,662 Posts
Cheers SkyBlue, best bet for the air con is to buy a damaged donor or one which is mechanically terminal to donate the components from.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #15 ·
Oil

Noticed the oil mist seems to be a fine mist, so i am guessing it might just be a pipe that is blowing. It is over on the front off side of the engine bay where two pipes run in front of the radiator. Not having any problems with engine temperature and the oil levels seem to be ok.

I am working 6am till 4.15 this week so will look on Friday and try and get it sorted once and for all.

It starts perfectly and with the new battery on and the plip done the problems with it not starting seem to have gone.

Have used some cutting paste on the paint work and managed to tidy up some of the scratches of the wings

But the annoyance is this heater fan and gic lighter, hopefully can sort that out on Friday as need the socket for my tomtom.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #16 ·
Update

Wired in 2 new earths off the Cigar Lighter and Heater Blower switch and everything is now working fine.

Did some tests prior to fitting the new earths and seems to be a broken wire on the old earth and the new earths seemed to solve this problem. But was fun removing the centre console and had to fit a lot of screws that seemed to be missing to hold it in place afterwards.

Bought some paint so next job is to sort out the few bits of rust and chips then need to get hold of a new aerial mount for the roof. For after i have rubbed the rust down and removed the sealer that was put around the current mount to stop it leaking. (any idea where these can be bought from?)

Been a few weeks now since got the new plips done and no problems with starting the car since so glad that is now sorted.

Then last job is to get up to Telford and collect a rear bumper that is as new in Tahiti Blue, for a 10 year old car it is starting to look really good now.

Gaz

PS any one know of any production ops (BIW) jobs going in the car industry as looks like i might be finished a lot sooner than planned
 
1 - 17 of 17 Posts
Top