MG-Rover.org Forums banner

1 - 9 of 9 Posts

·
Registered
mg_zs
Joined
·
526 Posts
Discussion Starter · #1 · (Edited)
400 Problems Running (juddering and stalling)

Hi There,

I was happly driving along a road fairly lively, car was doing great then all of a sudden i get juddering. I lost all power altogether and had to pretty much roll in.
I took off the air filter and tried starting, started ok. Gave it some trottle but it wouldn't respond. It would stop at 2000rpm. The only way i would be able to get it up to 6rpm would be to constantly blip the trottle (ie keep pressing on accellerater off and on and it woudl eventually climb)

Nothing seems wrong with engine only can't get it to rev high enough. Even having it reved to 2k, i wouldn't be able to pull off. No way would it go anywhere.

Next I leave it cool down for about 2 mins, start it. It starts no problem, and i can pull away and drive normally for litterly 5 seconds and then it would stall up on me and no way i could move unless i left it cooled agian.

One guy said it could be dirty petrol - possibilty as i filled the tank up a bit about 20 miles before that.

Any suggestions? Car is parked way back the road so want to get it sorted as soon as possible. Cheers
 

·
Registered
mg_zs
Joined
·
526 Posts
Discussion Starter · #7 ·
Thanks lads.

I went there to get it towed home but thought id chance driving it home (safer at moment as a rally on and nothing but traffic)

It drove home no problem what so ever. This was a 10 - 15 minute drive.
It was very hot today - you think maybe that the extreme heat effected some electrical components?

I would think it not the fuel filter now? Even though no harm changing it anyways.
 
1 - 9 of 9 Posts
Top