MG-Rover.org Forums banner
1 - 8 of 8 Posts

·
Registered
mg_6_gt
Joined
·
1,580 Posts
Discussion Starter · #1 ·
Just bought a 51plate Rover 25 1.6 iXL, and am quite impressed with it, far quicker than I imagined it to be, and great fun to drive.

There are a couple of minor niggles with it though. I could take the car to Pheonix MG-Rover Kidderminster to sort out, but would like to try myself first to save some money!

Firstly, the rear washer motor runs but the water pisses out on the floor by the rear passenger side door with none going near the window. I am guessing that the pipe is split and needs replacing, but is this correct, and if so is it a difficult job.

Also, the rear demister does not work. The switch works and the light comes on and stays on as it is supposed to, and the relay picks and latches correctly, but the screen does not demist. Any ideas?

Thanks in advance.
 

·
Registered
rover_45
Joined
·
255 Posts
my pipe went where it goes into the boot from the car body (top corner - black rubber 'insulation' round it) - easy job - just get a bit of spare tube, heat it in boiling water to soften and push both ends on. I think this is a common problem, and usually occurs in same place.
 

·
Registered
Joined
·
4,994 Posts
The wiring to the Heated rear screen is in the opposite rubber boot, on the RHS of the tailgate.

However, the plugs are visible i believe, one on the left and one on the right.

If it is loom damage, you will need to pull the rubber boot sown to see it.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top