MG-Rover.org Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
To cut a long story short im just going to sum up whats happend,basically the head gasket went on my gti sohc honda engine so i fixed it, but afterwards got a waterleak from the metal pipe that runs down the back of the engine. I replaced the pipe and the thermostat housing and put new o rings both ends but at high revs it still started leaking again so i filled the header tank with k-seal which stopped the leak but after about 4 weeks my header tank decided to fill up to the brim with water overflowing out the header tank basically i noticed a white foam party inside the tank so i flushed the whole water system 3 times and everytime i bled the system it came out pure white foam so im pretty certain k-seal caused it because everything has been fine since draining and refilling with fresh water if anyone has any other ideas whats happend please reply.
 

·
Registered
rover_200_coupe
Joined
·
694 Posts
K seal won't give a white foam, furthermore flushing it out will get rid of all of its 'in situ' properties.

When you say 'foam' do you mean like milkshake, slightly brown in colour and lumpy? or do you mean fairy liquid type foam?

Sounds like to me, your new head gasket has gone again and the repeated water leak was caused by over pressurization of the cooling system caused by head gasket failure. You putting in K seal, hid the symptoms for a while. until it has eventually completely gone...This is why, although I sing the praises of K seal, its only a quick fix, the actual fault needs to always be repaired as soon as you can, even if its a small leak. Its probably leaking for a reason.

What exactly is happening: when you turn it over.. is it boiling or bubbling (Compounded with this foam) Do you have like a thin film of grease under the coolant cap? Any evidence of emulsified oil/water on dip/oil filler cap (Mayo) Any water out the exhaust? or steam?

Hows your heater does it blow hot or cold or act normally when engine is warm.

Hope you can answer these as it will narrow down whats up with it. But as for K seal causing it... I would probably say its something more serious.

Sean
 

·
Registered
Joined
·
81 Posts
Discussion Starter #3
cars fine now

No the car is now perfectly normal again now the waters fine the oils fine and its going quicker then it ever did before there isnt actually much pressure there when you release the cap im pretty certain the head is still all ok.
 

·
Registered
rover_200_coupe
Joined
·
694 Posts
I've never seen K seal do that at all...

Heard a similar tale once when someone cleaned out the cooling system with fairy liquid, during a head gasket change. Although I know thats probably not what you did... Just one of those really odd things I guess.. Very strange.
 
1 - 5 of 5 Posts
Top