MG-Rover.org Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi all,got a rover 214sei 94' vintage,runs ok till hot then will tickover but not rev up,put strobe on and its losing its spark,ive changed the plugs,the dizzy cap/rotor arm,leads,and the coil,so i assumed it was "the brain",ive tried 2 now,with matched serial no's and it still isnt right,do you have to re-program the brain or should it work straight away,any advice would be gratefully recieved as i am out of ideas!Its a great car apart from this problem....Thanks in hope of some usefull advice!....
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Well was hoping for some advice on how to solve the problem,it is up for sale for the right dosh,but id rather fix it and keep it thanks,probably something simple to fix that im missing cus im so annoyed with it!So do i have to re-program ecu or what?,need to use car so running out of time before it gets changed for a ford or something more reliable!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Strange,thought it either worked or not(the crank sensor),ive tried a matched ecu but it starts up and cuts out again straight away,has anyone had experience of this sort of problem?,can the crank sensor cause an intermitent fault?
 

·
Registered
Joined
·
17,819 Posts
fastdagda said:
Strange,thought it either worked or not(the crank sensor),ive tried a matched ecu but it starts up and cuts out again straight away,has anyone had experience of this sort of problem?,can the crank sensor cause an intermitent fault?
You need to get the ECU coded to your immobiliser ECU or it will cut out after 1 second!
 

·
Premium Member
Joined
·
79,177 Posts
fastdagda said:
Strange,thought it either worked or not(the crank sensor),ive tried a matched ecu but it starts up and cuts out again straight away,has anyone had experience of this sort of problem?,can the crank sensor cause an intermitent fault?
Crank sensors are affected by engine heat, classic symptoms!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #12 ·
Well i have to say thanks guys,I got hold of a crank sensor from Best Of British in birmingham,£20 with p+p,seems to have sorted it!,fingers crossed!,thanks for all the advice and no doubt ill speak to you guys again,when it goes wrong!well it is a rover!LOL,see ya later..p.s.anyone need an ecu?i have 3 spares now!!!
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top