MG-Rover.org Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Took my car (214 SLi, L Reg, 1994) for it's MOT on Thursday, and it failed on emissions. The guy at Kwik Fit checked it, and he's putting the blame down to a rusted front pipe (bit that goes from the exhaust manifold to the CAT). Now I've had a look and it's mainly hole free, apart from where it joins to the manifold, where it is very corroded and has a few holes that are a few mm in size.

So I took it to National to see if they could fit a new front pipe - they couldn't as the bolts on the exhaust manifold gasket had seized to the old front pipe, and they couldn't get them off. They mentioned the car might need a new exhaust manifold as well, but they don't fit them.

So I'm kind of stuck - I can't really afford to buy a new front pipe AND an exhaust manifold. Any ideas on ways to free the front pipe from the exhaust manifold? Could I bodge it with Gun Gum (with the intention of buying a new exhaust system in a few months)?

Emissions readout was as follows:

Fast Idle Test:
Engine Speed: 2500-3000rpm PASS
CO: Limit <=0.3% Actual=3.595% FAIL
HC: Limit <=200ppm Actual=172ppm PASS
Lambda: Limit: 0.97-1.03 Actual=0.899 FAIL

Second Fast Idle Test:
Engine Speed: 2500-3000rpm PASS
CO: Limit <=0.3% Actual=1.421% FAIL
HC: Limit <=200ppm Actual=117ppm PASS
Lambda: Limit: 0.97-1.03 Actual=0.979 PASS

Natural Idle:
Engine Speed: 450-1500rpm PASS
CO: Limit <=0.5% Actual=0.335% PASS
 

·
Registered
other_rover
Joined
·
226 Posts
leaking exhaust will only affect the CO readings if its upstream of the lambda sensor causeing the lambda sensor to think the engine is lean and causeing more fuel to ge tput in causeing a fail. if the lambda's ok you could always find a backstreat garage that will blat some weld over the holes to get you through this mot?

either that or its your lambda sensor thats gone.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
evolotion said:
leaking exhaust will only affect the CO readings if its upstream of the lambda sensor causeing the lambda sensor to think the engine is lean and causeing more fuel to ge tput in causeing a fail. if the lambda's ok you could always find a backstreat garage that will blat some weld over the holes to get you through this mot?

either that or its your lambda sensor thats gone.
When the car had it's service the engine was running rich, so exhaust must be to blame then? The lambda readings were almost at what they should be, so prime culprit then.

I'll see if I can get it welded/replaced :)

Cheers :)
 
1 - 3 of 3 Posts
Top