MG-Rover.org Forums banner
1 - 3 of 3 Posts

· Registered
cityrover
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi to you all, new member with an MG GS clutch pedal problem. I bought the car four days ago from PINKSTONES MG STOKE, and twice my clutch on depression has stayed down. On pulling the pedal back by hand it works ok again but alas yesterday it stayed down again. On pulling the pedal back the car moved with difficulty and the smell of the clutch burning was bad. Eventually I got the car to Pinkstones and left it with them, they phoned MG Longbridge who said they have never heard of the problem but to go ahead and fix it. My worry is what might be causing the problem?? I dont want to be fobbed off with a story to come back again with the same problem. I have read on line that some MG3'S have had a similar problem caused through a faulty rubber seal....Help I need some knowledge.
 

· Registered
mg_tf
Joined
·
501 Posts
Hi Mike and welcome to this forum. I’ve got one of these and I’m up to 23K miles. I’ve had one issue fixed under warranty, other than that the cars been great.

Assuming the clutch is hydraulic (I’ll have look later today) it should be reasonably simple, consisting of two main parts, the clutch pedal/master cylinder and slave cylinder. The most likely slave cylinder arrangement will be a concentric slave cylinder and release bearing.

If this is the case the pedal would be returned by 2 forces, the main one being the springs in the clutch acting via the release bearing and the slave cylinder pushing the pedal back hydraulically, and I’d also expect a small spring on the pedal that would return it to its home position and prevent rattle.

The issue with the 3’s was apparently a seal within the master cylinder and your symptoms sound very similar.

You’ve taken it back to the supplying dealer and the car has a 5 year warranty, it’s their responsibility to fix it both as the supplying dealer and it’s under warranty.

Before you accept the car back ask what they’ve done to fix it, unless they’ve done something specific ie replaced the master cylinder, it’s quite likely it’ll happen again. These things don’t fix themselves, they may go away for a while but unless you replace the part that’s causing the problem it won’t be fixed.
 

· Registered
mg_tf
Joined
·
501 Posts
I was correct in my assumptions, it’s a simple hydraulic system. The symptoms sound very similar to the issue with the 3. My wife had this happen with her 3, they changed the master cylinder and it’s never happened again.

What was slightly worrying with the issue on my wife’s 3 was that not only did the pedal stick down a couple of times, it was also leaking fluid, although I couldn’t find where. As it uses the same reservoir for brakes and clutch the fluid was very low before we realised what was happening. The GS has the same arrangement of a shared reservoir.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top