MG-Rover.org Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
I have had my car 9 months from new, noticed a horrible whining from my transmission. I have test drove another mg zr from a garage and 1 of my mates zr's and they were fine with no sounds out of the ordinary!

I have got it booked in on friday because i thought i better have it checked while its still under warranty!

My Q. is, do any of you lot know what the cause could be, just in case mg (rover) want to try and get out of fixing the problem??!!

Any help would be a massive help and then at least i could go in armed with some knowledge.

Also my exhaust is blowing from somewhere in the middle, this should be covered under the warranty shouldnt it ??

thanks in advance (wezzer)
 

·
Registered
Joined
·
2,603 Posts
wezz69 said:
I have had my car 9 months from new, noticed a horrible whining from my transmission. I have test drove another mg zr from a garage and 1 of my mates zr's and they were fine with no sounds out of the ordinary!

I have got it booked in on friday because i thought i better have it checked while its still under warranty!

My Q. is, do any of you lot know what the cause could be, just in case mg (rover) want to try and get out of fixing the problem??!!

Any help would be a massive help and then at least i could go in armed with some knowledge.

Also my exhaust is blowing from somewhere in the middle, this should be covered under the warranty shouldnt it ??

thanks in advance (wezzer)
Id say both should be covered under warranty.

Sounds like one of the bearings in the box has shot it.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
better put my standard air filter back on, if they see the k&n then my car will keep its damn whine!!

DONT WANT OR NEED THAT HASSLE
 
1 - 4 of 4 Posts
Top