MG-Rover.org Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi All

Have just aquired a 1996 420GSI tourer. I understand from reading the manual that whenever I unlock it, the interior light should come on. Unfortunately, this does not happen, neither does it happen when I open the doors. The light will work form the switch, but not the doors or remote locking. The alam does not seem to work either, but the immobiliser does. I have looked in the Haynes and there is no specific indication as to what may have gone wrong, but the wiring diagram suggests that there is a solid state gizmo behind the fuse board which controls various electronic aspects.

Any suggestions as to what may have happened before I get the local auto electricians involved?

Any help would be appreciated.

Many thanks

Bryn :confused:
 

·
Registered
rover_45
Joined
·
11,628 Posts
Have you got an alarm fob. If you have not then the light should not come on. Also check the door switches for any that are broken or rusty. The MFU is the thing you are on about but the alarm unit controls the interior light circuit. Does the central locking work on the car.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Hi Sejin

I have both the original key fobs and they both work. The Door switches seem to be clean and working properly and they are earthing without any problems. The central locking works both from the key fob and from the key without any problems. It just seems to be the courtesy light and alarm that do not want to operate.

I assume that from what you are saying, it may be the alarm unit that has gone Kaput. If so, is there any way of testing it?

many thanks

Bryn
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top