MG-Rover.org Forums banner
problem
1-5 of 5 Results
  1. Introduce yourself
    Hi everyone, I'm currently in the process of a full engine rebuild and I've run across a major electrical issue, yesterday i wound down the passenger window and when I tried to wind it back up it wound up the drivers side window instead so I had to take off the passenger door card and manually...
  2. MG ZR / Rover 25, 200 & Streetwise
    This 1.8 k series I have has been fully rebuilt down to every bolt, ever since refitting and starting I've had a misfire with it, after a while it disappears and is fine but when it does misfire and I'm in 1st its so sluggish and then it will just bolt and be ok, but when you change down gears...
  3. MG ZR / Rover 25, 200 & Streetwise
    Now the indicators on my r200 work fine on the hazards but with the indicator stalk there's no activity at all, they worked before and now they've packed up. Any help would be much appreciated as its you solve one problem creating a new one.
  4. Introduce yourself
    I am having problems with a Cityrover Sprite rear screen washer. There is no water coming through to the rear washer, although the front on works perfectly. I have checked the tubing connecting the rear washer and it is clear, and the one way valve works as well. Anyone else have the same...
  5. How Do I - Answers To Common Problems.
    hi there my mg tf has this problem where, once i unlock the car and open the door the hazard lights come on and when i shut the door takes about 40 seconds for them to go off. .. hasnt really bothered me untill now. when i bought the car it came with a new alarm and then when unlocked sounds...
1-5 of 5 Results
Top